Goal Zero Yeti 1400 issue, awaiting tech support response from Goal Zero

The following email was sent to Goal Zero on November 29th, 2020. As of Jan 11th, 2021 I have not received a response.

Hello and thank you in advance for your assistance.

Issue:
I have a Yeti 1400 Lithium (non-wifi) unit that will not work properly.
Specifically, the display does not stay on, none of the power output options (AC/DC/USB)  work, and the Yeti will not charge.
Specific Diagnostic Symptoms:

All displays/lights are off and nothing will power onConnecting a charger results in the unit beeping 3 times, the display lighting up briefly, and then the display turning off.

One charging properly, the other not charging

I have tried all the different charging ports and the same behavior happens.  I have tried resetting the Yeti by pressing the “Unit” and “Info” buttons for 3 seconds. This did not resolve the issue.

Additional info:

I have additional Goal Zero 1400, 1000 and 3000 units. They are all working properly and I have verified that the charger(s) I am using are working properly.
Request:

I would greatly appreciate you forwarding this issue to your tech support department in the hopes they can help me fix my Yeti 1400. Thank you and have a GREAT day 🙂


Best regards,-J.D.

NOTE: as of 2021/01/11 I am trying Goal Zero’s chat support seeking a resolution to the issue. UPDATE: They are supposed to be sending return authorization. 👍📦

Chat transcript:

Charly

Hi JD, thank you for contacting Goal Zero.

I’d be happy to help! What seems to be the issue with your Yeti 1400?

JD:

Hi Charly! Thank you for your help,

I had reached out to Goal Zero via support email, but did not get a response, so I will copy paste the info here 🙂 Thank you! One moment please,

Issue: I have a Yeti 1400 Lithium (non-wifi) unit that will not work properly. Specifically, the display does not stay on, none of the power output options (AC/DC/USB) work, and the Yeti will not charge. Specific Diagnostic Symptoms: All displays/lights are off and nothing will power on Connecting a charger results in the unit beeping 3 times, the display lighting up briefly, and then the display turning off. I have tried all the different charging ports and the same behavior happens. I have tried resetting the Yeti by pressing the “Unit” and “Info” buttons for 3 seconds. This did not resolve the issue. Additional info: I have additional Goal Zero 1400, 1000 and 3000 units. They are all working properly and I have verified that the charger(s) I am using are working properly.

(photo attached)

Charly

Alright, that is very unusual. Do you know when and where you purchased the Yeti 1400?

JD

Thank you Charly, yes one moment please while I look up the purchase info.

I have a lot of Goal Zero stuff (love your products!) but I believe this one was purchased directly from Goal Zero,

Order Number: XXXXXX

Tracking number is XXXXXXXX

Charly

Perfect! Just give me one moment here.

JD

Certainly!

Charly

Alright, if you could just confirm your shipping address I can go ahead and get a return authorization set up for you! It looks like we’ll want to set up a warranty replacement.

JD

That sounds great Charly! Thank you so much,

___ADDRESS___

Charly

Absolutely. Is there anything else I can do for you today?

Thank you, it will be just a few minutes and then I will send the instructions to your email.

JD

Certainly! I greatly appreciate your help!

Charly

Not a problem, you have a wonderful day!

JD

Thank you again Charly, you made my day. I will be so happy to get my Yeti 1400 fixed. You have a great day too! Bye

[END CHAT]

Leave a Reply

Your email address will not be published. Required fields are marked *